Ask Your Question
0

우분투 16.04 실행 문제

asked 2019-03-19 11:27:29 +0900

casper7609 gravatar image

안녕하세요! 14.04 버전 지원이 종료된다고 하여 16.04 버전으로 올릴려고 하는 중입니다.

레퍼런스 문서의 5. 개발환경(C#): Linux + Monodevelop 부분까지 진행하고 서버를 실행시키려 하는데 빌드는 완료가 되나 밑의 메세지가 뜨면서 서버가 실행되지는 않네요. 확인 부탁드립니다!

Loaded assembly: /usr/bin/funapi_monodevelop_helper.exe [External] This is a dummy .exe file for Monodevelop. Do nothing.

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2019-03-19 11:31:48 +0900

gigone.lee gravatar image

updated 2019-03-19 11:32:09 +0900

안녕하세요 아이펀팩토리 입니다.

Monodevelop 좌측 상단에 보이는 화살표 버튼 옆에 체크 박스가 하나 있는데요.

그 체크 박스를 클릭하면 다음과 같은 두 가지 옵션을 볼 수 있습니다.

  • {project_name}
  • {project_name}-Custom Command

혹시 첫 번째 항목으로 설정된 경우라면 두 번째 항목으로 바꾼 후 다시 시도해주시면 감사하겠습니다.

edit flag offensive delete link more

Comments

시도해보았는데 Cannot execute "~~project_name.dll" The selected execution mode is not supported for .Net projects. 메세지가 뜨면서 시작이 안됩니다

casper7609 gravatar imagecasper7609 ( 2019-03-19 11:39:01 +0900 )edit

다음 두 가지 사항을 확인해주실 수 있을까요?

  1. 최신 버전의 mono-devel 설치 여부 (https://ifunfactory.com/engine/docume... 문서에 있는 절차를 따라주시면 됩니다)

  2. 사용 중이신 MonoDevelop IDE 버전 (상단에 있는 Help -> About)

gigone.lee gravatar imagegigone.lee ( 2019-03-19 11:43:53 +0900 )edit

1번 사항은 다시 따라서 적용해보았습니다 ㅠㅠ 2번 사항은 7.7(build 1869)로 나옵니다.

casper7609 gravatar imagecasper7609 ( 2019-03-19 11:53:53 +0900 )edit

https://ifunfactory.com/engine/docume... 항목을 참고하셔서 빌드 결과물이 저장된 디렉토리를 삭제한 후 다시 시도해주실 수 있을까요?

gigone.lee gravatar imagegigone.lee ( 2019-03-19 11:57:09 +0900 )edit

추가로 {프로젝트 이름}/mono/bin/Debug 안에 첫 코멘트에서 적어주신 로그에 해당하는 {프로젝트 이름}.dll 이 존재하는지도 한번 확인해주시면 감사하겠습니다.

gigone.lee gravatar imagegigone.lee ( 2019-03-19 11:58:20 +0900 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-03-19 11:27:29 +0900

Seen: 23 times

Last updated: Mar 19