[서포터즈] 패키징 후 배포한뒤 연결 실패 현상 [closed]

asked 2018-08-06 12:35:12 +0900

superamped gravatar image

updated 2018-08-06 19:16:30 +0900

안녕하세요!

비쥬얼 스튜디오로 ORM을 이용하여 데이터를 넣고 확인하는거까지 테스트 완료했습니다.

유니티 테스트 클라이언트에서 TCP로 데이터를 날리면 서버에서 받아서 처리하고 응답메세지까지 정상적으로 오는데요

우분트 테스트서버에 소스폴더에서 cmake 한뒤 make clean 다시 make pacakage 를 하고 dpkg 설치까지 했습니다.

처음엔 제가 설정을 잘못해서 서비스 등록및 실행이 안되서 dpkg 를 제거 후 다시 재설치를 여러번했는데요

결국엔 서비스 등록 및 서비스 실행까지 정상적으로 구동되었습니다.

클라이언트에서 다시 테스트를 시도하니

Broadcast message from systemd-journald@ubuntu (Sun 2018-08-05 19:32:35 UTC):

i_fun_engine_example_server.default[4693]: Assert failed: outputFile:

콘솔창에 이러한 실패 메세지가 뜨고 클라이언트 로그에도 접속 실패가 뜨네요

혹시나 해서 /etc/default/ 경로로 가서 런처에 로그출력 옵션을 더해서 직접 실행해봤습니다.

이부분부터가 오류가 발생하는 부분인데요

E0805 19:42:24.154207 5122 socket.cc:635] failed to bind listen address: Address already in use. error_code=system:98, listen_address=0.0.0.0:8014 F0805 19:42:24.154505 5122 manifest_handler.cc:748] Assert failed: started: Failed to start 'ApiService'

Broadcast message from systemd-journald@ubuntu (Sun 2018-08-05 19:42:24 UTC):

i_fun_engine_example_server.default[5122]: Assert failed: started: Failed to start 'ApiService'

* Check failure stack trace: * E0805 19:42:24.154862 5122 framework.cc:54] System has been crashed. (1.0.0-2619xenial) E0805 19:42:24.154876 5122 framework.cc:64] Shutdown AccountManager. E0805 19:42:24.154886 5122 framework.cc:64] Shutdown EventDispatcher. E0805 19:42:24.255102 5122 framework.cc:64] Shutdown ObjectTransaction. E0805 19:42:24.255223 5122 framework.cc:64] Shutdown ObjectDatabase. I0805 19:42:24.255237 5122 object_database.cc:3599] Flushing 0 update queries /usr/share/funapi/bash/launcher-common.sh: line 89: 5122 Aborted (core dumped) $fork_prefix $FUNAPI_BIN_DIR/funapi_runner $args $@ [ERROR] i_fun_engine_example_server@ubuntu termianted with 134.

Analyzing crashdump /var/crash/funapi/i_fun_engine_example/5ac30717-cf48-4f48-57e69c4c-33ca57dd.dmp

OS Linux 0.0.0 Linux 4.4.0-130-generic #156-Ubuntu SMP Thu Jun 14 08:53:28 UTC 2018 x86_64 CPU amd64 family 23 model 17 stepping 0 2 Crash SIGSEGV 0x7f457b5afe00 0

0 libglog.so.0.0.0 (+0xb5f1) 1 libglog.so.0.0.0 (+0x21e420) 2 libglog.so.0.0.0 (+0x21e480) 3 libglog.so.0.0.0 (+0xd433) 4 libglog.so.0.0.0 (+0x21e440) 5 funapi_runner: _fini (+0x4a6bc) 6 funapi_runner: _fini (+0x4a6db) 7 libc-2.23.so (+0x100be2) 8 libglog.so.0.0.0 (+0x18fbf) 9 libglog.so.0.0.0 (+0xb15b) 10 libglog.so.0.0.0 (+0xb379) 11 funapi_runner: fun::StartComponents() (+0x43b) 12 funapi_runner: _init (+0x1600) 13 (+0x7f456850d2c0) 14 funapi_runner: HandleProtobufLogMessage(google::protobuf::LogLevel, char const*, int, std::__cxx11::basic_string<char, std::char_traits<char="">, std::allocator<char> > const&) (+0xb00) 15 funapi_runner: main (+0xef1)

Run "/usr/bin/funapi_stackwalk '/var/crash/funapi/i_fun_engine_example/5ac30717-cf48-4f48-57e69c4c-33ca57dd.dmp' /usr/share/i_fun_engine_example/default/symbols /usr/share/funapi/symbols" to display crash-info

이 오류가 발생해서 접속이 안되는것이 맞나요??

혹 제가 빠트린 셋팅이 있거나 IDE 상에서 디버그 할때와는 다르게 릴리즈할때는 뭔가 다른 셋팅이 있는건지.. 궁금하네요

참고로 우분투버전은 16버전이구요 유투브에 올려주신 튜토리얼에 리눅스 셋팅 참고해서 설치했습니다.

더 필요한 정보가 있으면 알려주시면 덧글에 올리겠습니다.

감사합니다!

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by superamped
close date 2018-08-08 01:38:40.374718

Comments

자문자답이지만.. 해결했습니다 포트 문제였네요;;; 하는김에 테스트용으로 쓰던 ubuntu 계정을 안쓰고 제 개인계정으로 새로 만들고 sudo 권한 을 부여해서 작업했습니다. 잘 붙네요 ㅎㅎ ㅠㅠ

superamped gravatar imagesuperamped ( 2018-08-08 01:38:31 +0900 )edit