Ask Your Question
0

'rpc_redis_hosts' configuration is not correct. 이란 에러가 나오는데요.

asked 2020-03-24 23:18:58 +0900

koadoctor gravatar image

updated 2020-03-24 23:56:22 +0900

퐁설치를하고 실행을 하려고 했더니 'rpc_redis_hosts' configuration is not correct. 이런 에러가 나오면서 안되는데요.

zookeeper나 redis 모두 설치되어있고 실행이 잘 되어있는 상태입니다.

뭐가 문제 인지 모르겠네요. 뭘 수정해야 할까요?

그리고 퐁 설명서에 파일목록과 현재 나온 파일 목록들도 다르네요.

수정을 해주시면 안될까요?

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2020-03-25 17:10:20 +0900

seonyul.park gravatar image

안녕하세요 아이펀팩토리 입니다.

rpc 기능 사용 시 zookeeper 와 redis 중 사용할 서비스를 선택해야 합니다.

기존에는 기본 값으로 zookeeper 를 사용하였나 최근 rpc 기본 값이 redis 로 변경되어 설정 변경이 필요합니다.

수정이 필요한 부분은 곧 적용하여 업로드 할 예정입니다.

우선은 직접 설정 값을 변경하여 사용해 주시면 감사하겠습니다.

설정 값 변경은 다음과 같이 하시면 됩니다.

각 flavor 의 MANIFEST/RpcService 하위에 "rpc_backend" : "zookeeper"를 추가해 주세요.

또는

"rpc_redis_hosts": [
  {
    "host": "127.0.0.1:6379",
    "database": 0  // 생략하면 기본 값 0 으로 작동합니다.
    "auth": ""     // 생략하거나 빈 문자열을 입력하면 AUTH 를 진행하지 않습니다.
  }

를 추가하여 redis 를 사용하도록 설정하셔도 됩니다.

감사합니다.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-03-24 23:18:58 +0900

Seen: 8 times

Last updated: Mar 25