Ask Your Question
0

아이펀 엔진 업데이트 이후 오류 관련 문의

asked 2020-03-12 10:59:05 +0900

bkkim gravatar image

updated 2020-03-12 11:16:07 +0900

Jinuk gravatar image

fuapi1-runtime_1.0.0-5080xenial: stable 버전으로 업그레이드 이후 다음과 같은 오류가 발생합니다.

I0312 10:41:53.599819 14529 manifest_handler.cc:848] Starting RpcService
I0312 10:41:53.599843 14529 rpc_service.cc:1737] Started RPC e0d55ec6-415b-4d1f-0000-000000000000, 192.168.0.7:8013
I0312 10:41:53.599889 14529 rpc_service.cc:1741] RPC server handshaking completed: peer=e0d55ec6-415b-4d1f-0000-000000000000(self)

Broadcast message from systemd-journald@bob_ch01 (Thu 2020-03-12 10:41:53 KST):
ifun_server.chat[14529]: 'rpc_redis_hosts' configuration is not correct.
F0312 10:41:53.602710 14529 redis_rpc_service.cc:646] 'rpc_redis_hosts' configuration is not correct.
E0312 10:41:53.604635 14529 main.cc:511] Fatal log information: thread=funapi_runner

Thread 1 "funapi_runner" received signal SIGABRT, Aborted.
0x00007ffff3a27428 in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:54
Aborted

다음은 manifest 정보입니다.

 "Redis": {
            "enable_redis": false,
            "redis_mode": "redis",
            "redis_servers": {
              "": {
                "address": "192.168.0.32:6379",
                "database": 0,
                "auth_pass": ""
              }
            },
            "redis_sentinel_servers": {
              "": {
                "master_name": "mymaster",
                "addresses": ["127.0.0.1:26379"],
                "database": 0,
                "auth_pass": ""
              }
            },
            "redis_async_threads_size": 4
          },

 "RpcService": {
            "rpc_enabled": true,
            "rpc_threads_size": 4,
            "rpc_port": 8013,
            "rpc_nic_name": "",  // if not specified, uses first NIC appeared in predictable network interface names.
            "rpc_tags": ["ch 1","chat" ],
            "rpc_message_logging_level": 0,
            "rpc_disable_tcp_nagle": true,
            "enable_rpc_reply_checker": true
            // Set followings if use Redis instead Zookeeper.
            // "rpc_backend_zookeeper": false,
            // "rpc_redis_hosts": ["127.0.0.1"],
            // "rpc_redis_connection_count": 16,
            // "rpc_redis_master_update_interval_in_seconds": 5,
            // "rpc_redis_session_timeout_in_seconds": 10,
            // "rpc_redis_recovery_window_size_in_sec": 6
          },
edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2020-03-12 11:15:31 +0900

seonyul.park gravatar image

안녕하세요. 아이펀 팩토리 입니다.

프로젝트를 새로 생성할 경우 rpc backend 가 Redis 로 설정되는데 Redis 관련 설정이 없어서 발생한 문제입니다.

Zookeeper 를 사용하도록 설정하거나, Redis 관련 설정을 추가해 주셔야합니다.

Zookeeper 를 사용하도록 설정하려면 MANIFEST/RpcServicerpc_backend 를 추가하시고 값으로 "zookeeper" 를 입력해 주세요.

"rpc_backend": "zookeeper" 와 같이 추가해 주시면 됩니다.

그리고 현재는 Zookeeper 보다는 Redis 를 권장하고 있습니다. 아래 링크의 설명을 참고하셔서 Redis 를 사용하도록 설정하실 수 있습니다. https://www.ifunfactory.com/engine/do...

감사합니다.

edit flag offensive delete link more

Comments

감사합니다. 문제 해결했습니다.

bkkim gravatar imagebkkim ( 2020-03-12 14:48:03 +0900 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-03-12 10:59:05 +0900

Seen: 19 times

Last updated: Mar 12