Ask Your Question
0

rpc is turned off 에러(2016-09-18, david_yoo)

asked 2016-11-30 18:07:04 +0900

inkeun.kim gravatar image

현재 매치메이킹 활용하여 서버 만드는중인데... 어제까지 잘되가가 갑자기 이렇게 RPC 에러가 나오네요.. 왜그런걸까요... ㅠ_ㅠ

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2016-11-30 18:07:50 +0900

inkeun.kim gravatar image

Answer by david_yoo · 2016-09-19 AM 06:45

이렇게 true 로 하고 클린 해도 계속덤프남기네요...

재시작해도 동일합니다.

빌드가 되긴하는것 같은데.... 계속 에러가 나는게 좀 걸리네요 ㅠㅠ

edit flag offensive delete link more
0

answered 2016-11-30 18:07:11 +0900

inkeun.kim gravatar image

Answer by DK.Moon · 2016-09-18 AM 08:00

안녕하세요.

MANIFEST.json 에 Rpc 콤포넌트에 "enabled": true 로 되어있는지 확인해주시겠어요? 매치메이킹 클라이언트는 RPC 를 이용해서 매치메이킹 서버와 통신을 해야되서 RPC 에 대한 의존성을 가지고 있고, RPC 가 활성화 되어있어야 하는데 로그 메시지를 봤을 때 이게 꺼져 있는 것 같습니다.

edit flag offensive delete link more

Comments

david_yoo · 2016-09-19 AM 06:40 0 True 값으로 되어있는데도 이렇게 에러가 나네요...

inkeun.kim gravatar imageinkeun.kim ( 2016-11-30 18:07:20 +0900 )edit

Answer by minwoo.seok · 2016-09-19 AM 08:37

안녕하세요.

처음 첨부하신 이미지의 내용으로 미루어 짐작해보았을 때 CLion 설정이 일부 안된 것 같습니다.

다음 문서에서 설명하는 CLion IDE 사용하기의 3번 내용을 참고하여 설정을 변경하신 후에 다시 한번 확인 부탁 드립니다.

http://www.ifunfactory.com/engine/doc...

감사합니다.

inkeun.kim gravatar imageinkeun.kim ( 2016-11-30 18:07:32 +0900 )edit

david_yoo · 2016-09-20 PM 11:49 1 말씀하신데로 하니 잘되네요 :)

원래 해당 빌드 폴더에서 ./sss-local 로 실행했는데 ide에서 바로 실행되네요.

감사합니다 :)

inkeun.kim gravatar imageinkeun.kim ( 2016-11-30 18:07:43 +0900 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-11-30 18:07:04 +0900

Seen: 82 times

Last updated: Nov 30 '16