Ask Your Question
0

ifunapi1-dev 설치 중 에러

asked 2019-10-17 18:40:07 +0900

yongjupark gravatar image

updated 2019-10-17 18:40:51 +0900

funapi 문제가 있는듯 하여 지우고 다시 설치 중에 에러가 발생하여 문의드립니다. funapi1-dev를 설치하려고하면 아래 내용과 같은 에러가 발생합니다.

$ sudo apt-get install funapi1-dev 패키지 목록을 읽는 중입니다... 완료 의존성 트리를 만드는 중입니다
상태 정보를 읽는 중입니다... 완료 몇몇 패키지를 설치할 수 없습니다. 요청한 상황이 불가능할 수도 있고, 불안정 배포판을 사용해서 일부 필요한 패키지를 아직 만들지 않았거나, 아직 Incoming에서 나오지 않은 경우일 수도 있습니다. 이 상황을 해결하는데 다음 정보가 도움이 될 수도 있습니다:

다음 패키지의 의존성이 맞지 않습니다: funapi1-dev : 의존: libmono-system2.0-cil 하지만 %s 패키지를 설치하지 않을 것입니다 혹은 mono-reference-assemblies-2.0 하지만 %s 패키지를 설치하지 않을 것입니다 E: 문제를 바로잡을 수 없습니다. 망가진 고정 패키지가 있습니다.

ubuntu 18.04를 사용중입니다.

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2019-10-18 09:36:56 +0900

jwlee gravatar image

안녕하세요. 현재 설치되어 있는 Mono 관련 패키지들의 의존성이 문제인 것 같습니다. cat /etc/apt/sources.list.d/mono-xamarin.list 명령과 dpkg --list | grep mono | awk '{print $2, $3}' 명령의 결과를 올려주시면 확인 해 보겠습니다.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-10-17 18:40:07 +0900

Seen: 39 times

Last updated: Oct 18